CVE-2012-5643

NameCVE-2012-5643
DescriptionMultiple memory leaks in tools/cachemgr.cc in cachemgr.cgi in Squid 2.x and 3.x before 3.1.22, 3.2.x before 3.2.4, and 3.3.x before 3.3.0.2 allow remote attackers to cause a denial of service (memory consumption) via (1) invalid Content-Length headers, (2) long POST requests, or (3) crafted authentication credentials.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2631-1
NVD severitymedium (attack range: remote)
Debian Bugs696187
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
squid (PTS)squeeze2.7.STABLE9-2.1fixed
squeeze (lts)2.7.STABLE9-2.1+deb6u1fixed
wheezy2.7.STABLE9-4.1fixed
wheezy (security)2.7.STABLE9-4.1+deb7u1fixed
sid2.7.STABLE9-5fixed
squid3 (PTS)squeeze, squeeze (security)3.1.6-1.2+squeeze3fixed
squeeze (lts)3.1.6-1.2+squeeze4fixed
wheezy, wheezy (security)3.1.20-2.2+deb7u2fixed
stretch, sid, jessie3.4.8-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
squidsource(unstable)2.7.STABLE9-2medium
squid3source(unstable)3.1.20-2.1medium696187
squid3sourcesqueeze3.1.6-1.2+squeeze3mediumDSA-2631-1

Notes

squid-cgi was removed in 2.7.STABLE9-2
possible regression, see #701123

Search for package or bug name: Reporting problems