CVE-2012-5651

NameCVE-2012-5651
DescriptionDrupal 6.x before 6.27 and 7.x before 7.18 displays information for blocked users, which might allow remote attackers to obtain sensitive information by reading the search results.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2776-1
NVD severitymedium (attack range: remote)
Debian Bugs696342, 696343
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
drupal6 (PTS)squeeze (security), squeeze6.31-1fixed
drupal7 (PTS)wheezy, wheezy (security)7.14-2+deb7u8fixed
jessie, sid7.32-1+deb8u1fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
drupal6source(unstable)(unfixed)medium696343
drupal6sourcesqueeze6.28-1mediumDSA-2776-1
drupal7source(unstable)7.14-1.2medium696342

Notes

http://drupal.org/SA-CORE-2012-004

Search for package or bug name: Reporting problems