CVE-2012-5667

NameCVE-2012-5667
DescriptionMultiple integer overflows in GNU Grep before 2.11 might allow context-dependent attackers to execute arbitrary code via vectors involving a long input line that triggers a heap-based buffer overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: local)
Debian Bugs701897

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
grep (PTS)wheezy2.12-2fixed
jessie2.20-4.1fixed
stretch2.27-2fixed
buster, sid3.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
grepsource(unstable)2.11-1low701897
grepsourcesqueeze2.6.3-3+squeeze1medium

Notes

https://bugs.launchpad.net/ubuntu/+source/grep/+bug/1091473
patch http://git.savannah.gnu.org/cgit/grep.git/commit/?id=cbbc1a45b9f843c811905c97c90a5d31f8e6c189
http://www.openwall.com/lists/oss-security/2012/12/22/1

Search for package or bug name: Reporting problems