CVE-2012-5688

NameCVE-2012-5688
DescriptionISC BIND 9.8.x before 9.8.4-P1 and 9.9.x before 9.9.2-P1, when DNS64 is enabled, allows remote attackers to cause a denial of service (assertion failure and daemon exit) via a crafted query.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs695192

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
bind9 (PTS)bullseye (security), bullseye1:9.16.48-1fixed
bookworm, bookworm (security)1:9.18.24-1fixed
sid, trixie1:9.19.24-185-g392e7199df2-1fixed
isc-dhcp (PTS)bullseye4.4.1-2.3+deb11u2fixed
bullseye (security)4.4.1-2.3+deb11u1fixed
bookworm4.4.3-P1-2fixed
sid, trixie4.4.3-P1-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
bind9sourcesqueeze(not affected)
bind9source(unstable)1:9.8.4.dfsg.P1-1695192
isc-dhcpsource(unstable)(not affected)

Notes

[squeeze] - bind9 <not-affected> (Only affects 9.8 and 9.9)
- isc-dhcp <not-affected> (issue only affects the named service, which isn't used by isc-dhcp)

Search for package or bug name: Reporting problems