CVE-2012-5842

NameCVE-2012-5842
DescriptionMultiple unspecified vulnerabilities in the browser engine in Mozilla Firefox before 17.0, Firefox ESR 10.x before 10.0.11, Thunderbird before 17.0, Thunderbird ESR 10.x before 10.0.11, and SeaMonkey before 2.14 allow remote attackers to cause a denial of service (memory corruption and application crash) or possibly execute arbitrary code via unknown vectors.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2583-1, DSA-2584-1, DSA-2588-1
NVD severityhigh (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
iceape (PTS)squeeze (security)2.0.11-17fixed
icedove (PTS)squeeze, squeeze (security)3.0.11-1+squeeze15fixed
wheezy31.3.0-1~deb7u1fixed
wheezy (security)31.6.0-1~deb7u1fixed
stretch, sid, jessie31.6.0-1fixed
iceweasel (PTS)squeeze, squeeze (security)3.5.16-20fixed
wheezy31.3.0esr-1~deb7u1fixed
wheezy (security)31.6.0esr-1~deb7u1fixed
stretch, sid, jessie31.6.0esr-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
iceapesource(unstable)2.7.11-1high
iceapesourcesqueeze2.0.11-17highDSA-2584-1
icedovesource(unstable)10.0.11-1high
icedovesourcesqueeze3.0.11-1+squeeze15highDSA-2588-1
iceweaselsource(unstable)10.0.11esr-1high
iceweaselsourcesqueeze3.5.16-20highDSA-2583-1

Search for package or bug name: Reporting problems