CVE-2012-5854

NameCVE-2012-5854
DescriptionHeap-based buffer overflow in WeeChat 0.3.6 through 0.3.9 allows remote attackers to cause a denial of service (crash or hang) and possibly execute arbitrary code via crafted IRC colors that are not properly decoded.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs693026

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
weechat (PTS)jessie1.0.1-1+deb8u2fixed
jessie (security)1.0.1-1+deb8u1fixed
stretch1.6-1+deb9u2fixed
buster2.3-1fixed
bullseye, sid2.6-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
weechatsource(unstable)0.3.9.1-1693026
weechatsourcesqueeze(not affected)
weechatsourcewheezy0.3.8-1+deb7u1

Notes

[squeeze] - weechat <not-affected> (Vulnerable code not present)

Search for package or bug name: Reporting problems