CVE-2012-5976

NameCVE-2012-5976
DescriptionMultiple stack consumption vulnerabilities in Asterisk Open Source 1.8.x before 1.8.19.1, 10.x before 10.11.1, and 11.x before 11.1.2; Certified Asterisk 1.8.11 before 1.8.11-cert10; and Asterisk Digiumphones 10.x-digiumphones before 10.11.1-digiumphones allow remote attackers to cause a denial of service (daemon crash) via TCP data using the (1) SIP, (2) HTTP, or (3) XMPP protocol.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2605-1
NVD severitymedium (attack range: remote)
Debian Bugs697230
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
asterisk (PTS)squeeze, squeeze (security)1:1.6.2.9-2+squeeze12fixed
wheezy, wheezy (security)1:1.8.13.1~dfsg1-3+deb7u3fixed
stretch, jessie1:11.13.1~dfsg-2fixed
sid1:13.1.0~dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
asterisksource(unstable)1:1.8.13.1~dfsg-2medium697230
asterisksourcesqueeze1:1.6.2.9-2+squeeze9mediumDSA-2605-1

Notes

http://downloads.digium.com/pub/security/AST-2012-014.pdf

Search for package or bug name: Reporting problems