CVE-2012-6075

NameCVE-2012-6075
DescriptionBuffer overflow in the e1000_receive function in the e1000 device driver (hw/e1000.c) in QEMU 1.3.0-rc2 and other versions, when the SBP and LPE flags are disabled, allows remote attackers to cause a denial of service (guest OS crash) and possibly execute arbitrary guest code via a large packet.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2607-1, DSA-2608-1, DSA-2619-1
NVD severityhigh (attack range: remote)
Debian Bugs696051
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qemu (PTS)squeeze (security), squeeze0.12.5+dfsg-3squeeze4fixed
wheezy, wheezy (security)1.1.2+dfsg-6a+deb7u6fixed
jessie, sid1:2.1+dfsg-11fixed
qemu-kvm (PTS)squeeze (security), squeeze0.12.5+dfsg-5+squeeze11fixed
wheezy, wheezy (security)1.1.2+dfsg-6+deb7u6fixed
xen (PTS)squeeze (security), squeeze4.0.1-5.11fixed
wheezy4.1.4-3+deb7u3fixed
wheezy (security)4.1.4-3+deb7u5fixed
jessie, sid4.4.1-8fixed
xen-qemu-dm-4.0 (PTS)squeeze (security), squeeze4.0.1-2+squeeze3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qemusource(unstable)1.1.2+dfsg-4high696051
qemusourcesqueeze0.12.5+dfsg-3squeeze3highDSA-2608-1
qemu-kvmsource(unstable)1.1.2+dfsg-4high696051
qemu-kvmsourcesqueeze0.12.5+dfsg-5+squeeze10highDSA-2607-1
xensource(unstable)4.1.3-8high
xensourcesqueeze(not affected)
xen-qemu-dm-4.0sourcesqueeze4.0.1-2+squeeze3highDSA-2619-1

Notes

[squeeze] - xen <not-affected> (In Squeeze the code is in the package xen-qemu-dm-4.0)
http://www.openwall.com/lists/oss-security/2012/12/30/1

Search for package or bug name: Reporting problems