CVE-2012-6085

NameCVE-2012-6085
DescriptionThe read_block function in g10/import.c in GnuPG 1.4.x before 1.4.13 and 2.0.x through 2.0.19, when importing a key, allows remote attackers to corrupt the public keyring database or cause a denial of service (application crash) via a crafted length field of an OpenPGP packet.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2601-1
NVD severitymedium (attack range: remote, user-initiated)
Debian Bugs697108, 697251
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gnupg (PTS)squeeze (security), squeeze1.4.10-4+squeeze4fixed
squeeze (lts)1.4.10-4+squeeze7fixed
wheezy1.4.12-7+deb7u6fixed
wheezy (security)1.4.12-7+deb7u7fixed
jessie, sid1.4.18-7fixed
gnupg2 (PTS)squeeze (security), squeeze2.0.14-2+squeeze2fixed
squeeze (lts)2.0.14-2+squeeze3fixed
wheezy, wheezy (security)2.0.19-2+deb7u2fixed
jessie, sid2.0.26-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gnupgsource(unstable)1.4.12-7medium697108
gnupgsourcesqueeze1.4.10-4+squeeze1mediumDSA-2601-1
gnupg2source(unstable)2.0.19-2medium697251
gnupg2sourcesqueeze2.0.14-2+squeeze1mediumDSA-2601-1

Search for package or bug name: Reporting problems