CVE-2012-6147

NameCVE-2012-6147
DescriptionCross-site scripting (XSS) vulnerability in the tree render API (TCA-Tree) in the Backend API in TYPO3 4.5.x before 4.5.21, 4.6.x before 4.6.14, and 4.7.x before 4.7.6 allows remote authenticated backend users to inject arbitrary web script or HTML via unspecified vectors.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2574-1
NVD severitylow (attack range: remote, user-initiated)
Debian Bugs692775
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot known to be vulnerable.
Debian/testingnot known to be vulnerable.
Debian/unstablenot known to be vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
typo3-src (PTS)squeeze, squeeze (security)4.3.9+dfsg1-1+squeeze9fixed
wheezy4.5.19+dfsg1-5+wheezy3fixed
wheezy (security)4.5.19+dfsg1-5+wheezy4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
typo3-srcsource(unstable)4.5.19+dfsg1-4low692775
typo3-srcsourcesqueeze4.3.9+dfsg1-1+squeeze7lowDSA-2574-1

Notes

https://review.typo3.org/16305

Search for package or bug name: Reporting problems