CVE-2012-6426

NameCVE-2012-6426
DescriptionLemonLDAP::NG before 1.2.3 does not use the signature-verification capability of the Lasso library, which allows remote attackers to bypass intended access-control restrictions via crafted SAML data.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs696329

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
lemonldap-ng (PTS)jessie1.3.3-1fixed
jessie (security)1.3.3-1+deb8u2fixed
stretch1.9.7-3+deb9u2fixed
stretch (security)1.9.7-3+deb9u1fixed
buster2.0.2+ds-7+deb10u1fixed
buster (security)2.0.2+ds-7+deb10u2fixed
bullseye, sid2.0.6+ds-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
lemonldap-ngsource(unstable)1.2.2-3696329
lemonldap-ngsourcesqueeze(not affected)
lemonldap-ngsourcewheezy1.1.2-5+deb7u1

Notes

[squeeze] - lemonldap-ng <not-affected> (SAML code not present)

Search for package or bug name: Reporting problems