CVE-2012-6496

NameCVE-2012-6496
DescriptionSQL injection vulnerability in the Active Record component in Ruby on Rails before 3.0.18, 3.1.x before 3.1.9, and 3.2.x before 3.2.10 allows remote attackers to execute arbitrary SQL commands via a crafted request that leverages incorrect behavior of dynamic finders in applications that can use unexpected data types in certain find_by_ method calls.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2597-1
NVD severityhigh (attack range: remote)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rails (PTS)squeeze (security), squeeze2.3.5-1.2+squeeze8fixed
wheezy2:2.3.14.2fixed
sid, jessie2:4.1.8-1fixed
ruby-activerecord-2.3 (PTS)wheezy2.3.14-6fixed
ruby-activerecord-3.2 (PTS)wheezy, wheezy (security)3.2.6-5+deb7u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
railssource(unstable)2.3.14.1high
railssourcesqueeze2.3.5-1.2+squeeze4highDSA-2597-1
ruby-activerecord-2.3source(unstable)2.3.14-3high
ruby-activerecord-3.2source(unstable)3.2.6-3high

Notes

Starting with 2.3.14.1 rails is a transition package

Search for package or bug name: Reporting problems