CVE-2012-6497

NameCVE-2012-6497
DescriptionThe Authlogic gem for Ruby on Rails, when used with certain versions before 3.2.10, makes potentially unsafe find_by_id method calls, which might allow remote attackers to conduct CVE-2012-6496 SQL injection attacks via a crafted parameter in environments that have a known secret_token value, as demonstrated by a value contained in secret_token.rb in an open-source product.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2597-1
NVD severitymedium (attack range: remote)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rails (PTS)squeeze (security), squeeze2.3.5-1.2+squeeze8fixed
wheezy2:2.3.14.2fixed
jessie, sid2:4.1.8-1fixed
ruby-activerecord-2.3 (PTS)wheezy2.3.14-6fixed
ruby-activerecord-3.2 (PTS)wheezy, wheezy (security)3.2.6-5+deb7u1fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
railssource(unstable)2.3.14.1medium
railssourcesqueeze2.3.5-1.2+squeeze4mediumDSA-2597-1
ruby-activerecord-2.3source(unstable)2.3.14-3medium
ruby-activerecord-3.2source(unstable)3.2.6-3medium

Notes

Starting with 2.3.14.1 rails is a transition package

Search for package or bug name: Reporting problems