CVE-2012-6535

NameCVE-2012-6535
DescriptionDjVuLibre before 3.5.25.3, as used in Evince, Sumatra PDF Reader, VuDroid, and other products, allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted DjVu (aka .djv) file.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2844-1
NVD severityhigh (attack range: remote, user-initiated)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
djvulibre (PTS)squeeze, squeeze (security)3.5.23-3+squeeze1fixed
wheezy3.5.25.3-1fixed
jessie3.5.25.4-4fixed
stretch, sid3.5.27.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
djvulibresource(unstable)3.5.25.3-1high
djvulibresourcesqueeze3.5.23-3+squeeze1highDSA-2844-1

Notes

http://sourceforge.net/p/djvu/djvulibre-git/ci/d4f0f6d37fe6a1fb427cfa33a64ead1eff32d28e/
evince doesnt use an embedded version of this

Search for package or bug name: Reporting problems