CVE-2012-6639

NameCVE-2012-6639
DescriptionAn privilege elevation vulnerability exists in Cloud-init before 0.7.0 when requests to an untrusted system are submitted for EC2 instance data.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cloud-init (PTS)stretch0.7.9-2fixed
buster20.2-2~deb10u1fixed
bullseye, sid20.2-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cloud-initsource(unstable)0.7.1-1

Notes

http://article.gmane.org/gmane.comp.security.oss.general/12299

Search for package or bug name: Reporting problems