CVE-2012-6685

NameCVE-2012-6685
DescriptionNokogiri before 1.5.4 is vulnerable to XXE attacks
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-229-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ruby-nokogiri (PTS)buster1.10.0+dfsg1-2fixed
buster (security)1.10.0+dfsg1-2+deb10u1fixed
bullseye1.11.1+dfsg-2fixed
bookworm1.13.7+dfsg-2fixed
sid1.13.8+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libnokogiri-rubysourcesqueeze1.4.0-4+deb6u1DLA-229-1
libnokogiri-rubysource(unstable)(unfixed)
ruby-nokogirisource(unstable)1.5.4-1low

Notes

https://github.com/sparklemotion/nokogiri/issues/693
Full fix requires fixing CVE-2014-0191 in libxml2 too.

Search for package or bug name: Reporting problems