CVE-2012-6698

NameCVE-2012-6698
DescriptionThe decode_search function in dhcp.c in dhcpcd 3.x allows remote DHCP servers to cause a denial of service (out-of-bounds write) via a crafted response.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-362-1, DSA-3534-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
dhcpcd (PTS)sid, trixie1:10.0.8-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
dhcpcdsourcesqueeze1:3.2.3-5+squeeze2DLA-362-1
dhcpcdsourcewheezy1:3.2.3-11+deb7u1DSA-3534-1
dhcpcdsource(unstable)1:10.0.1-1

Notes

https://launchpadlibrarian.net/228152582/dhcp.c.patch
original ubuntu bug: https://bugs.launchpad.net/ubuntu/+source/dhcpcd/+bug/1517226
epoch'ed 1:10.0.1-1 is technically not fully correct as the epoch only has been
re-introduced in 1:10.0.1-3, cf #1040714

Search for package or bug name: Reporting problems