CVE-2012-6707

NameCVE-2012-6707
DescriptionWordPress through 4.8.2 uses a weak MD5-based password hashing algorithm, which makes it easier for attackers to determine cleartext values by leveraging access to the hash values. NOTE: the approach to changing this may not be fully compatible with certain use cases, such as migration of a WordPress site from a web host that uses a recent PHP version to a different web host that uses PHP 5.2. These use cases are plausible (but very unlikely) based on statistics showing widespread deployment of WordPress with obsolete PHP versions.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs880868

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress (PTS)wheezy3.6.1+dfsg-1~deb7u10vulnerable
wheezy (security)3.6.1+dfsg-1~deb7u20vulnerable
jessie4.1+dfsg-1+deb8u15vulnerable
jessie (security)4.1+dfsg-1+deb8u16vulnerable
stretch4.7.5+dfsg-2+deb9u1vulnerable
stretch (security)4.7.5+dfsg-2+deb9u2vulnerable
buster, sid4.9.2+dfsg-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wordpresssource(unstable)(unfixed)medium880868

Notes

https://core.trac.wordpress.org/ticket/21022
Proposed patch (but not merged): https://core.trac.wordpress.org/attachment/ticket/21022/21022.3.diff
Cf. https://core.trac.wordpress.org/ticket/21022#comment:80 and following.

Search for package or bug name: Reporting problems