CVE-2013-0155

NameCVE-2013-0155
DescriptionRuby on Rails 3.0.x before 3.0.19, 3.1.x before 3.1.10, and 3.2.x ...
SourceCVE (at NVD; oss-sec, OSVDB, EDB, Red Hat, Ubuntu, Gentoo, SuSE, more)
ReferencesDSA-2609-1
Debian Bugs697744, 697802
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rails (PTS)squeeze, squeeze (security)2.3.5-1.2+squeeze8fixed
wheezy2:2.3.14.2fixed
jessie, sid2:3.2.13+1fixed
ruby-actionpack-3.2 (PTS)wheezy3.2.6-6fixed
wheezy (security)3.2.6-6+deb7u1fixed
sid3.2.16-3fixed
ruby-activerecord-2.3 (PTS)wheezy2.3.14-6fixed
ruby-activerecord-3.2 (PTS)wheezy3.2.6-5fixed
sid3.2.16-1fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
railssource(unstable)2.3.14.1
railssourcesqueeze2.3.5-1.2+squeeze5DSA-2609-1
ruby-actionpack-3.2source(unstable)3.2.6-5697802
ruby-activerecord-2.3source(unstable)2.3.14-4
ruby-activerecord-3.2source(unstable)3.2.6-4697744

Notes

Starting with 2.3.14.1 rails is a transition package
http://www.openwall.com/lists/oss-security/2013/01/08/13

Search for package or bug name: Reporting problems

Home - Testing Security Team - Debian Security - Source (SVN)