CVE-2013-0156

NameCVE-2013-0156
Descriptionactive_support/core_ext/hash/conversions.rb in Ruby on Rails before 2.3.15, 3.0.x before 3.0.19, 3.1.x before 3.1.10, and 3.2.x before 3.2.11 does not properly restrict casts of string values, which allows remote attackers to conduct object-injection attacks and execute arbitrary code, or cause a denial of service (memory and CPU consumption) involving nested XML entity references, by leveraging Action Pack support for (1) YAML type conversion or (2) Symbol type conversion.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2604-1
NVD severityhigh (attack range: remote)
Debian Bugs697722, 697789, 697790
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rails (PTS)squeeze, squeeze (security)2.3.5-1.2+squeeze8fixed
wheezy2:2.3.14.2fixed
jessie2:4.1.8-1fixed
stretch, sid2:4.1.10-1fixed
ruby-activesupport-2.3 (PTS)wheezy2.3.14-7fixed
ruby-activesupport-3.2 (PTS)wheezy, wheezy (security)3.2.6-6+deb7u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
railssource(unstable)2.3.14.1high697722
railssourcesqueeze2.3.5-1.2+squeeze4.1highDSA-2604-1
ruby-activesupport-2.3source(unstable)2.3.14-5high697789
ruby-activesupport-3.2source(unstable)3.2.6-5high697790

Notes

Starting with 2.3.14.1 rails is a transition package
http://www.insinuator.net/2013/01/rails-yaml/
http://www.openwall.com/lists/oss-security/2013/01/08/14
experimental has 3.2.8-1 and should be affected too

Search for package or bug name: Reporting problems