CVE-2013-0166

NameCVE-2013-0166
DescriptionOpenSSL before 0.9.8y, 1.0.0 before 1.0.0k, and 1.0.1 before 1.0.1d does not properly perform signature verification for OCSP responses, which allows remote OCSP servers to cause a denial of service (NULL pointer dereference and application crash) via an invalid key.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2621-1
NVD severitymedium (attack range: remote)
Debian Bugs699889
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openssl (PTS)squeeze (security), squeeze0.9.8o-4squeeze14fixed
squeeze (lts)0.9.8o-4squeeze20fixed
wheezy1.0.1e-2+deb7u13fixed
wheezy (security)1.0.1e-2+deb7u16fixed
sid, jessie1.0.1k-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
opensslsource(unstable)1.0.1e-1medium699889
opensslsourcesqueeze0.9.8o-4squeeze14mediumDSA-2621-1

Search for package or bug name: Reporting problems