CVE-2013-0184

NameCVE-2013-0184
DescriptionUnspecified vulnerability in Rack::Auth::AbstractRequest in Rack 1.1.x before 1.1.5, 1.2.x before 1.2.7, 1.3.x before 1.3.9, and 1.4.x before 1.4.4 allows remote attackers to cause a denial of service via unknown vectors related to "symbolized arbitrary strings."
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2783-1
NVD severitymedium (attack range: remote)
Debian Bugs698440
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
librack-ruby (PTS)squeeze, squeeze (security)1.1.0-4+squeeze2fixed
squeeze (lts)1.1.0-4+squeeze3fixed
ruby-rack (PTS)wheezy1.4.1-2.1fixed
wheezy (security)1.4.1-2.1+deb7u1fixed
jessie1.5.2-3fixed
jessie (security)1.5.2-3+deb8u1fixed
stretch, sid1.5.2-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
librack-rubysource(unstable)(unfixed)medium
librack-rubysourcesqueeze1.1.0-4+squeeze1mediumDSA-2783-1
ruby-racksource(unstable)1.4.1-2.1medium698440

Search for package or bug name: Reporting problems