CVE-2013-0209

NameCVE-2013-0209
Descriptionlib/MT/Upgrade.pm in mt-upgrade.cgi in Movable Type 4.2x and 4.3x through 4.38 does not require authentication for requests to database-migration functions, which allows remote attackers to conduct eval injection and SQL injection attacks via crafted parameters, as demonstrated by an eval injection attack against the core_drop_meta_for_table function, leading to execution of arbitrary Perl code.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2611-1
NVD severityhigh (attack range: remote)
Debian Bugs697666
Debian/oldstablenot known to be vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot known to be vulnerable.
Debian/unstablenot known to be vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
movabletype-opensource (PTS)squeeze (security)4.3.8+dfsg-0+squeeze4fixed
wheezy5.1.4+dfsg-4+deb7u1fixed
wheezy (security)5.1.4+dfsg-4+deb7u3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
movabletype-opensourcesource(unstable)5.1.2+dfsg-1high697666
movabletype-opensourcesourcesqueeze4.3.8+dfsg-0+squeeze3highDSA-2611-1

Notes

Versions 5.0 or higher not affected

Search for package or bug name: Reporting problems