CVE-2013-0242

NameCVE-2013-0242
DescriptionBuffer overflow in the extend_buffers function in the regular expression matcher (posix/regexec.c) in glibc, possibly 2.17 and earlier, allows context-dependent attackers to cause a denial of service (memory corruption and crash) via crafted multibyte characters.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-165-1
NVD severitymedium (attack range: remote)
Debian Bugs699399

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
eglibc (PTS)wheezy2.13-38+deb7u10fixed
wheezy (security)2.13-38+deb7u12fixed
glibc (PTS)jessie (security), jessie2.19-18+deb8u10fixed
stretch (security), stretch2.24-11+deb9u1fixed
buster, sid2.24-14fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
eglibcsource(unstable)(unfixed)medium
eglibcsourcesqueeze2.11.3-4+deb6u5mediumDLA-165-1
eglibcsourcewheezy2.13-38+deb7u1medium
glibcsource(unstable)2.17-2low699399

Notes

http://seclists.org/oss-sec/2013/q1/202

Search for package or bug name: Reporting problems