CVE-2013-0288

NameCVE-2013-0288
Descriptionnss-pam-ldapd before 0.7.18 and 0.8.x before 0.8.11 allows context-dependent attackers to cause a denial of service (application crash) and possibly execute arbitrary code by performing a name lookup on an application with a large number of open file descriptors, which triggers a stack-based buffer overflow related to incorrect use of the FD_SET macro.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2628-1
NVD severitymedium (attack range: remote)
Debian Bugs690319
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nss-pam-ldapd (PTS)squeeze, squeeze (security)0.7.15+squeeze4fixed
wheezy0.8.10-4fixed
jessie0.9.4-3fixed
stretch, sid0.9.6-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nss-pam-ldapdsource(unstable)0.8.10-3medium690319
nss-pam-ldapdsourcesqueeze0.7.15+squeeze3mediumDSA-2628-1

Search for package or bug name: Reporting problems