CVE-2013-0333

NameCVE-2013-0333
Descriptionlib/active_support/json/backends/yaml.rb in Ruby on Rails 2.3.x before 2.3.16 and 3.0.x before 3.0.20 does not properly convert JSON data to YAML data for processing by a YAML parser, which allows remote attackers to execute arbitrary code, conduct SQL injection attacks, or bypass authentication via crafted data that triggers unsafe decoding, a different vulnerability than CVE-2013-0156.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2613-1
NVD severityhigh (attack range: remote)
Debian Bugs699226, 699249
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rails (PTS)squeeze (security), squeeze2.3.5-1.2+squeeze8fixed
wheezy2:2.3.14.2fixed
jessie, sid2:4.1.8-1fixed
ruby-activesupport-2.3 (PTS)wheezy2.3.14-7fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
railssource(unstable)2.3.14.1high699226
railssourcesqueeze2.3.5-1.2+squeeze6highDSA-2613-1
ruby-activesupport-2.3source(unstable)2.3.14-6high699249

Notes

Starting with 2.3.14.1 rails is a transition package
https://groups.google.com/forum/?fromgroups=#!topic/rubyonrails-security/1h2DR63ViGo

Search for package or bug name: Reporting problems