CVE-2013-0337

NameCVE-2013-0337
DescriptionThe default configuration of nginx, possibly 1.3.13 and earlier, uses world-readable permissions for the (1) access.log and (2) error.log files, which allows local users to obtain sensitive information by reading the files.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)
Debian Bugs701112

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nginx (PTS)wheezy1.2.1-2.2+wheezy4vulnerable
wheezy (security)1.2.1-2.2+wheezy4+deb7u1vulnerable
jessie1.6.2-5+deb8u4vulnerable
jessie (security)1.6.2-5+deb8u5vulnerable
stretch (security), stretch1.10.3-1+deb9u1vulnerable
buster, sid1.13.5-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nginxsource(unstable)(unfixed)low701112

Notes

[stretch] - nginx <no-dsa> (Minor issue)
[jessie] - nginx <no-dsa> (Minor issue)
[wheezy] - nginx <no-dsa> (Minor issue)
[squeeze] - nginx <no-dsa> (Minor issue)
Can only be fixed properly once https://trac.nginx.org/nginx/ticket/376
resolved upstream.
Originally fixed in 1.4.4-2 but reintroduced with DSA-3701-1 fixes.

Search for package or bug name: Reporting problems