CVE-2013-0844

NameCVE-2013-0844
DescriptionOff-by-one error in the adpcm_decode_frame function in libavcodec/adpcm.c in FFmpeg before 1.0.4 allows remote attackers to have an unspecified impact via crafted DK4 data, which triggers an out-of-bounds array access.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2793-1
NVD severityhigh (attack range: remote, user-initiated)
Debian/oldoldstablepackage ffmpeg is vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ffmpeg (PTS)squeeze, squeeze (security)4:0.5.10-1vulnerable
squeeze (lts)4:0.5.10-1+deb6u1vulnerable
sid7:2.7.1-1fixed
libav (PTS)wheezy6:0.8.16-1fixed
wheezy (security)6:0.8.17-1fixed
jessie6:11.3-1+deb8u1fixed
jessie (security)6:11.4-1~deb8u1fixed
stretch, sid6:11.4-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ffmpegsource(unstable)7:2.4.1-1high
ffmpegsourcesqueeze(unfixed)end-of-life
libavsource(unstable)6:9.10-1high
libavsourcewheezy6:0.8.9-1highDSA-2793-1

Notes

[squeeze] - ffmpeg <end-of-life> (Backports to 0.5.x not useful, too many checks missing)
ffmpeg commit: http://git.videolan.org/?p=ffmpeg.git;a=commitdiff;h=f18c873ab5ee3c78d00fdcc2582b39c133faecb4
libav commit: http://git.libav.org/?p=libav.git;a=commitdiff;h=12576afe206d35231ccd61f9033c5fdab6a11e08
Fixed in 0.8.9

Search for package or bug name: Reporting problems