CVE-2013-0845

NameCVE-2013-0845
Descriptionlibavcodec/alsdec.c in FFmpeg before 1.0.4 allows remote attackers to have an unspecified impact via a crafted block length, which triggers an out-of-bounds write.
SourceCVE (at NVD; LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2855-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ffmpeg (PTS)stretch, sid7:3.0.2-2fixed
libav (PTS)wheezy6:0.8.17-2fixed
wheezy (security)6:0.8.17-2+deb7u1fixed
jessie (security), jessie6:11.6-1~deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ffmpegsource(unstable)(not affected)
libavsource(unstable)6:9.11-1high
libavsourcewheezy6:0.8.10-1highDSA-2855-1

Notes

- ffmpeg <not-affected> (MPEG-4 ALS decoder not present in ffmpeg/0.5)
http://git.videolan.org/?p=ffmpeg.git;a=commitdiff;h=0ceca269b66ec12a23bf0907bd2c220513cdbf16
Fixed in revisions: v9-2748-g2a0fb72, v9.10-7-g3f7d890
http://git.libav.org/?p=libav.git;a=commitdiff;h=2a0fb72
http://git.libav.org/?p=libav.git;a=commitdiff;h=3f7d890

Search for package or bug name: Reporting problems