CVE-2013-0865

NameCVE-2013-0865
DescriptionThe vqa_decode_chunk function in libavcodec/vqavideo.c in FFmpeg before 1.0.4 and 1.1.x before 1.1.2 allows remote attackers to have an unspecified impact via a large (1) cbp0 or (2) cbpz chunk in Westwood Studios VQA Video file, which triggers an out-of-bounds write.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2855-1
NVD severityhigh (attack range: remote, user-initiated)
Debian Bugs717009
Debian/oldoldstablepackage ffmpeg is vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ffmpeg (PTS)squeeze, squeeze (security)4:0.5.10-1vulnerable
squeeze (lts)4:0.5.10-1+deb6u1vulnerable
sid7:2.7.1-1fixed
libav (PTS)wheezy6:0.8.16-1fixed
wheezy (security)6:0.8.17-1fixed
jessie6:11.3-1+deb8u1fixed
jessie (security)6:11.4-1~deb8u1fixed
stretch, sid6:11.4-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ffmpegsource(unstable)7:2.4.1-1high
ffmpegsourcesqueeze(unfixed)end-of-life
libavsource(unstable)6:9.8-1high717009
libavsourcewheezy6:0.8.10-1highDSA-2855-1

Notes

[squeeze] - ffmpeg <end-of-life> (Backports to 0.5.x not useful, too many checks missing)
libav commit: http://git.libav.org/?p=libav.git;a=commit;h=f7d18deb73d1dd1b27b2c7062c9a10d168a6c62a

Search for package or bug name: Reporting problems