CVE-2013-1362

NameCVE-2013-1362
DescriptionIncomplete blacklist vulnerability in nrpc.c in Nagios Remote Plug-In Executor (NRPE) before 2.14 might allow remote attackers to execute arbitrary shell commands via "$()" shell metacharacters, which are processed by bash.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)
Debian Bugs701227

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nagios-nrpe (PTS)jessie2.15-1fixed
stretch3.0.1-3+deb9u1fixed
bullseye, buster, sid3.2.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nagios-nrpesource(unstable)2.13-3low701227

Notes

[squeeze] - nagios-nrpe <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems