CVE-2013-1417

NameCVE-2013-1417
Descriptiondo_tgs_req.c in the Key Distribution Center (KDC) in MIT Kerberos 5 (aka krb5) 1.11 before 1.11.4, when a single-component realm name is used, allows remote authenticated users to cause a denial of service (daemon crash) via a TGS-REQ request that triggers an attempted cross-realm referral for a host-based service principal.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow
Debian Bugs730085

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
krb5 (PTS)stretch1.15-1+deb9u1fixed
stretch (security)1.15-1+deb9u2fixed
buster1.17-3+deb10u1fixed
buster (security)1.17-3+deb10u2fixed
bullseye1.18.3-6fixed
bookworm, sid1.18.3-7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
krb5sourcesqueeze(not affected)
krb5sourcewheezy(not affected)
krb5source(unstable)1.11.3+dfsg-3+nmu1low730085

Notes

[squeeze] - krb5 <not-affected> (Vulnerable code only present in 1.11.x)
[wheezy] - krb5 <not-affected> (Vulnerable code only present in 1.11.x)
https://github.com/krb5/krb5/commit/4c023ba43c16396f0d199e2df1cfa59b88b62acc

Search for package or bug name: Reporting problems