CVE-2013-1430

NameCVE-2013-1430
DescriptionAn issue was discovered in xrdp before 0.9.1. When successfully logging in using RDP into an xrdp session, the file ~/.vnc/sesman_${username}_passwd is created. Its content is the equivalent of the user's cleartext password, DES encrypted with a known key.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xrdp (PTS)wheezy0.5.0-2vulnerable
wheezy (security)0.5.0-2+deb7u1vulnerable
jessie0.6.1-2vulnerable
stretch, sid0.9.1-7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xrdpsource(unstable)0.9.1~2016121126+git5171fa7-1medium

Notes

[jessie] - xrdp <no-dsa> (Minor issue)
[wheezy] - xrdp <no-dsa> (Minor issue)
https://github.com/neutrinolabs/xrdp/pull/497
When successfully logging in using RDP into a xrdp session, the file
~/.vnc/sesman_${username}_passwd is created. Its content is the
equivalent of the users clear text password, DES encrypted with a known
key.

Search for package or bug name: Reporting problems