CVE-2013-1431

NameCVE-2013-1431
DescriptionThe Wocky module in Telepathy Gabble before 0.16.6 and 0.17.x before 0.17.4, when connecting to a "legacy Jabber server," does not properly enforce the WockyConnector:tls-required flag, which allows remote attackers to bypass TLS verification and perform a man-in-the-middle attacks.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2702-1
NVD severitymedium (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
telepathy-gabble (PTS)squeeze, squeeze (security)0.9.15-1+squeeze2fixed
wheezy0.16.7-0+deb7u1fixed
wheezy (security)0.16.5-1+deb7u1fixed
stretch, sid, jessie0.18.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
telepathy-gabblesource(unstable)0.16.6-1medium
telepathy-gabblesourcesqueeze0.9.15-1+squeeze2mediumDSA-2702-1
telepathy-gabblesourcewheezy0.16.5-1+deb7u1mediumDSA-2702-1

Search for package or bug name: Reporting problems