CVE-2013-1588

NameCVE-2013-1588
DescriptionMultiple buffer overflows in the dissect_pft_fec_detailed function in the DCP-ETSI dissector in epan/dissectors/packet-dcp-etsi.c in Wireshark 1.6.x before 1.6.13 and 1.8.x before 1.8.5 allow remote attackers to cause a denial of service (application crash) via a malformed packet.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2625-1
NVD severitylow (attack range: remote, user-initiated)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wireshark (PTS)squeeze, squeeze (security)1.2.11-6+squeeze14fixed
squeeze (lts)1.8.2-5wheezy16~deb6u1fixed
wheezy1.8.2-5wheezy12fixed
wheezy (security)1.8.2-5wheezy16fixed
jessie1.12.1+g01b65bf-4fixed
jessie (security)1.12.1+g01b65bf-4+deb8u2fixed
stretch1.12.6+gee1fce6-1fixed
sid1.12.7+g7fc8978-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wiresharksource(unstable)1.8.6-1low
wiresharksourcesqueeze1.2.11-6+squeeze9lowDSA-2625-1
wiresharksourcewheezy1.8.2-5wheezy1low

Notes

Upstream bug: https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=8213
Upstream patch: http://anonsvn.wireshark.org/viewvc?view=revision&revision=47098

Search for package or bug name: Reporting problems