CVE-2013-1635

NameCVE-2013-1635
Descriptionext/soap/soap.c in PHP before 5.3.22 and 5.4.x before 5.4.13 does not validate the relationship between the soap.wsdl_cache_dir directive and the open_basedir directive, which allows remote attackers to bypass intended access restrictions by triggering the creation of cached SOAP WSDL files in an arbitrary directory.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2639-1
NVD severityhigh (attack range: remote)
Debian Bugs702221
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php5 (PTS)squeeze (security), squeeze5.3.3-7+squeeze19fixed
squeeze (lts)5.3.3-7+squeeze25fixed
wheezy5.4.36-0+deb7u1fixed
wheezy (security)5.4.36-0+deb7u3fixed
jessie, sid5.6.6+dfsg-2fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php5source(unstable)5.4.4-14unimportant702221
php5sourcesqueeze5.3.3-7+squeeze15highDSA-2639-1

Notes

open_basedir not supported
http://git.php.net/?p=php-src.git;a=commitdiff;h=702b436ef470cc02f8e2cc21f2fadeee42103c74

Search for package or bug name: Reporting problems