CVE-2013-1654

NameCVE-2013-1654
DescriptionPuppet 2.7.x before 2.7.21 and 3.1.x before 3.1.1, and Puppet Enterprise 2.7.x before 2.7.2, does not properly negotiate the SSL protocol between client and master, which allows remote attackers to conduct SSLv2 downgrade attacks against SSLv3 sessions via unspecified vectors.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2643-1
NVD severitymedium (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
puppet (PTS)squeeze, squeeze (security)2.6.2-5+squeeze9fixed
squeeze (lts)2.6.2-5+squeeze10fixed
wheezy (security), wheezy2.7.23-1~deb7u3fixed
jessie3.7.2-4fixed
stretch3.7.2-5fixed
sid3.8.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
puppetsource(unstable)2.7.18-3medium
puppetsourcesqueeze2.6.2-5+squeeze7mediumDSA-2643-1

Search for package or bug name: Reporting problems