CVE-2013-1694

NameCVE-2013-1694
DescriptionThe PreserveWrapper implementation in Mozilla Firefox before 22.0, Firefox ESR 17.x before 17.0.7, Thunderbird before 17.0.7, and Thunderbird ESR 17.x before 17.0.7 does not properly handle the lack of a wrapper, which allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code by leveraging unintended clearing of the wrapper cache's preserved-wrapper flag.
SourceCVE (at NVD; LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2716-1, DSA-2720-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
icedove (PTS)wheezy31.8.0-1~deb7u1fixed
wheezy (security)38.8.0-1~deb7u1.1fixed
jessie31.8.0-1~deb8u1fixed
jessie (security)38.8.0-1~deb8u1fixed
stretch38.6.0-1fixed
sid38.7.2-1fixed
iceweasel (PTS)wheezy38.5.0esr-1~deb7u2fixed
wheezy (security)38.8.0esr-1~deb7u1fixed
jessie38.7.1esr-1~deb8u1fixed
jessie (security)38.8.0esr-1~deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
iceapesource(unstable)(unfixed)high
iceapesourcesqueeze(unfixed)end-of-life
iceapesourcewheezy(unfixed)end-of-life
icedovesource(unstable)17.0.7-1high
icedovesourcesqueeze(unfixed)end-of-life
icedovesourcewheezy17.0.7-1~deb7u1highDSA-2720-1
iceweaselsource(unstable)17.0.7esr-1high
iceweaselsourcesqueeze(unfixed)end-of-life
iceweaselsourcewheezy17.0.7esr-1~deb7u1highDSA-2716-1

Search for package or bug name: Reporting problems