CVE-2013-1737

NameCVE-2013-1737
DescriptionMozilla Firefox before 24.0, Firefox ESR 17.x before 17.0.9, Thunderbird before 24.0, Thunderbird ESR 17.x before 17.0.9, and SeaMonkey before 2.21 do not properly identify the "this" object during use of user-defined getter methods on DOM proxies, which might allow remote attackers to bypass intended access restrictions via vectors involving an expando object.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2759-1, DSA-2762-1
NVD severitymedium (attack range: remote)
Debian/oldoldstablepackages icedove, iceweasel are vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
icedove (PTS)squeeze, squeeze (security)3.0.11-1+squeeze15vulnerable
wheezy31.3.0-1~deb7u1fixed
wheezy (security)31.7.0-1~deb7u1fixed
stretch, jessie31.6.0-1fixed
jessie (security)31.7.0-1~deb8u1fixed
sid31.7.0-1fixed
iceweasel (PTS)squeeze, squeeze (security)3.5.16-20vulnerable
wheezy31.3.0esr-1~deb7u1fixed
wheezy (security)31.7.0esr-1~deb7u1fixed
stretch, jessie31.6.0esr-1fixed
jessie (security)31.7.0esr-1~deb8u1fixed
sid38.0.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
icedovesource(unstable)17.0.9-1medium
icedovesourcesqueeze(unfixed)end-of-life
icedovesourcewheezy17.0.9-1~deb7u1mediumDSA-2762-1
iceweaselsource(unstable)24.0-1medium
iceweaselsourcesqueeze(unfixed)end-of-life
iceweaselsourcewheezy17.0.9esr-1~deb7u1mediumDSA-2759-1

Search for package or bug name: Reporting problems