CVE-2013-1868

NameCVE-2013-1868
DescriptionMultiple buffer overflows in VideoLAN VLC media player 2.0.4 and earlier allow remote attackers to cause a denial of service (crash) and execute arbitrary code via vectors related to the (1) freetype renderer and (2) HTML subtitle parser.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2973-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vlc (PTS)wheezy, wheezy (security)2.0.3-5+deb7u2fixed
jessie2.2.6-1~deb8u1fixed
jessie (security)2.2.7-1~deb8u1fixed
stretch2.2.6-1~deb9u1fixed
stretch (security)2.2.7-1~deb9u1fixed
buster2.2.7-1fixed
sid2.2.8-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vlcsource(unstable)2.0.5-1high
vlcsourcesqueeze(unfixed)end-of-life
vlcsourcewheezy2.0.3-5+deb7u1highDSA-2973-1

Notes

[squeeze] - vlc <end-of-life> (Unsupported in squeeze-lts)
http://www.videolan.org/security/sa1301.html
The freetype issue is a harmless NULL deref and won't be fixed

Search for package or bug name: Reporting problems