CVE-2013-1912

NameCVE-2013-1912
DescriptionBuffer overflow in HAProxy 1.4 through 1.4.22 and 1.5-dev through 1.5-dev17, when HTTP keep-alive is enabled, using HTTP keywords in TCP inspection rules, and running with rewrite rules that appends to requests, allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via crafted pipelined HTTP requests that prevent request realignment from occurring.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2711-1
NVD severitymedium (attack range: remote)
Debian Bugs704611
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot known to be vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
haproxy (PTS)squeeze, squeeze (security)1.4.8-1+squeeze1fixed
stretch, jessie1.5.8-3fixed
sid1.5.11-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
haproxysource(unstable)1.4.23-1medium704611
haproxysourcesqueeze1.4.8-1+squeeze1mediumDSA-2711-1

Notes

http://git.1wt.eu/web?p=haproxy-1.4.git;a=commitdiff;h=dc80672211

Search for package or bug name: Reporting problems