CVE-2013-1913

NameCVE-2013-1913
DescriptionInteger overflow in the load_image function in file-xwd.c in the X Window Dump (XWD) plug-in in GIMP 2.6.9 and earlier, when used with glib before 2.24, allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a large color entries value in an X Window System (XWD) image dump.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-2813-1
Debian Bugs731305

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gimp (PTS)buster2.10.8-2fixed
buster (security)2.10.8-2+deb10u1fixed
bullseye2.10.22-4+deb11u2fixed
bullseye (security)2.10.22-4+deb11u1fixed
bookworm2.10.34-1+deb12u2fixed
bookworm (security)2.10.34-1+deb12u1fixed
trixie2.10.36-2fixed
sid2.10.36-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gimpsourcesqueeze2.6.10-1+squeeze4DSA-2813-1
gimpsourcewheezy2.8.2-2+deb7u1DSA-2813-1
gimpsource(unstable)2.8.10-0.1731305

Search for package or bug name: Reporting problems