CVE-2013-1915

NameCVE-2013-1915
DescriptionModSecurity before 2.7.3 allows remote attackers to read arbitrary files, send HTTP requests to intranet servers, or cause a denial of service (CPU and memory consumption) via an XML external entity declaration in conjunction with an entity reference, aka an XML External Entity (XXE) vulnerability.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2659-1
NVD severityhigh (attack range: remote)
Debian Bugs704625
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libapache-mod-security (PTS)squeeze2.5.12-1+squeeze3fixed
squeeze (security)2.5.12-1+squeeze2fixed
squeeze (lts)2.5.12-1+squeeze4fixed
modsecurity-apache (PTS)wheezy, wheezy (security)2.6.6-6+deb7u2fixed
jessie2.8.0-3fixed
stretch, sid2.8.0-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libapache-mod-securitysource(unstable)(unfixed)high
libapache-mod-securitysourcesqueeze2.5.12-1+squeeze2highDSA-2659-1
modsecurity-apachesource(unstable)2.6.6-6high704625

Notes

https://github.com/SpiderLabs/ModSecurity/commit/d4d80b38aa85eccb26e3c61b04d16e8ca5de76fe
http://marc.info/?l=oss-security&m=136499182131283&w=2

Search for package or bug name: Reporting problems