CVE-2013-1929

NameCVE-2013-1929
DescriptionHeap-based buffer overflow in the tg3_read_vpd function in drivers/net/ethernet/broadcom/tg3.c in the Linux kernel before 3.8.6 allows physically proximate attackers to cause a denial of service (system crash) or possibly execute arbitrary code via crafted firmware that specifies a long string in the Vital Product Data (VPD) data structure.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2668-1, DSA-2669-1
NVD severitymedium (attack range: local)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)wheezy3.2.65-1fixed
wheezy (security)3.2.68-1+deb7u3fixed
jessie3.16.7-ckt11-1fixed
jessie (security)3.16.7-ckt11-1+deb8u3fixed
stretch4.1.3-1fixed
sid4.1.6-1fixed
linux-2.6 (PTS)squeeze, squeeze (security)2.6.32-48squeeze6fixed
squeeze (lts)2.6.32-48squeeze13fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsource(unstable)3.8.11-1medium
linuxsourcewheezy3.2.41-2+deb7u2mediumDSA-2669-1
linux-2.6source(unstable)(unfixed)medium
linux-2.6sourcesqueeze2.6.32-48squeeze3mediumDSA-2668-1

Search for package or bug name: Reporting problems