CVE-2013-1940

NameCVE-2013-1940
DescriptionX.Org X server before 1.13.4 and 1.4.x before 1.14.1 does not properly restrict access to input events when adding a new hot-plug device, which might allow physically proximate attackers to obtain sensitive information, as demonstrated by reading passwords from a tty.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2661-1
NVD severitylow (attack range: local)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xorg-server (PTS)squeeze, squeeze (security)2:1.7.7-18fixed
squeeze (lts)2:1.7.7-18+deb6u3fixed
wheezy2:1.12.4-6+deb7u5fixed
wheezy (security)2:1.12.4-6+deb7u6fixed
jessie2:1.16.4-1fixed
stretch, sid2:1.17.2-1.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xorg-serversource(unstable)2:1.12.4-6low
xorg-serversourcesqueeze2:1.7.7-16lowDSA-2661-1

Search for package or bug name: Reporting problems