CVE-2013-1979

NameCVE-2013-1979
DescriptionThe scm_set_cred function in include/net/scm.h in the Linux kernel before 3.8.11 uses incorrect uid and gid values during credentials passing, which allows local users to gain privileges via a crafted application.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2669-1
NVD severitymedium (attack range: local)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)wheezy3.2.65-1fixed
wheezy (security)3.2.68-1+deb7u2fixed
jessie3.16.7-ckt11-1fixed
jessie (security)3.16.7-ckt11-1+deb8u2fixed
stretch, sid4.0.8-2fixed
linux-2.6 (PTS)squeeze, squeeze (security)2.6.32-48squeeze6fixed
squeeze (lts)2.6.32-48squeeze13fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsource(unstable)3.8.11-1medium
linuxsourcewheezy3.2.41-2+deb7u2mediumDSA-2669-1
linux-2.6source(unstable)(not affected)

Notes

- linux-2.6 <not-affected> (Introduced in 2.6.36)

Search for package or bug name: Reporting problems