CVE-2013-1988

NameCVE-2013-1988
DescriptionMultiple integer overflows in X.org libXRes 1.0.6 and earlier allow X servers to trigger allocation of insufficient memory and a buffer overflow via vectors related to the (1) XResQueryClients and (2) XResQueryClientResources functions.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2688-1
NVD severitymedium (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libxres (PTS)squeeze, squeeze (security)2:1.0.4-1+squeezefixed
wheezy (security), wheezy2:1.0.6-1+deb7u1fixed
stretch, sid, jessie2:1.0.7-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libxressource(unstable)2:1.0.6-1+deb7u1medium
libxressourcesqueeze2:1.0.4-1+squeezemediumDSA-2688-1
libxressourcewheezy2:1.0.6-1+deb7u1mediumDSA-2688-1

Search for package or bug name: Reporting problems