CVE-2013-1989

NameCVE-2013-1989
DescriptionMultiple integer overflows in X.org libXv 1.0.7 and earlier allow X servers to trigger allocation of insufficient memory and a buffer overflow via vectors related to the (1) XvQueryPortAttributes, (2) XvListImageFormats, and (3) XvCreateImage function.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2674-1
NVD severitymedium (attack range: remote)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libxv (PTS)squeeze, squeeze (security)2:1.0.5-1+squeeze1fixed
squeeze (lts)2:1.0.5-1+squeeze1+build1fixed
wheezy, wheezy (security)2:1.0.7-1+deb7u1fixed
jessie, sid2:1.0.10-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libxvsource(unstable)2:1.0.7-1+deb7u1medium
libxvsourcesqueeze2:1.0.5-1+squeeze1mediumDSA-2674-1
libxvsourcewheezy2:1.0.7-1+deb7u1mediumDSA-2674-1

Search for package or bug name: Reporting problems