CVE-2013-2002

NameCVE-2013-2002
DescriptionBuffer overflow in X.org libXt 1.1.3 and earlier allows X servers to cause a denial of service (crash) and possibly execute arbitrary code via crafted length or index values to the _XtResourceConfigurationEH function.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2680-1
NVD severitymedium (attack range: remote)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libxt (PTS)squeeze (security), squeeze1:1.0.7-1+squeeze1fixed
wheezy, wheezy (security)1:1.1.3-1+deb7u1fixed
jessie, sid1:1.1.4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libxtsource(unstable)1:1.1.3-1+deb7u1medium
libxtsourcesqueeze1:1.0.7-1+squeeze1mediumDSA-2680-1
libxtsourcewheezy1:1.1.3-1+deb7u1mediumDSA-2680-1

Search for package or bug name: Reporting problems