CVE-2013-2035

NameCVE-2013-2035
DescriptionRace condition in hawtjni-runtime/src/main/java/org/fusesource/hawtjni/runtime/Library.java in HawtJNI before 1.8, when a custom library path is not specified, allows local users to execute arbitrary Java code by overwriting a temporary JAR file with a predictable name in /tmp.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs708293

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
hawtjni (PTS)buster1.16-1fixed
bullseye1.17-1fixed
bookworm, sid1.18-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
hawtjnisourcewheezy1.0~+git0c502e20c4-3+deb7u1
hawtjnisource(unstable)1.10-1low708293

Search for package or bug name: Reporting problems